Its been a while...

Talk about E-Types here
User avatar

Topic author
ChrisC
Posts: 1273
Joined: Sun Feb 14, 2010 11:38 am
Location: Surrey UK
Contact:
Great Britain

#1 Its been a while...

Post by ChrisC » Wed Feb 27, 2019 12:47 pm

Sorry chaps, I have been away from this forum for a long time. No particular reason apart from lack of time at work. I am still enjoying the car (after 35 years of ownership) and my restoration seems to be holding up. The car now gets driven and its not the show car it once was. Road salt put a messy end to my lovely nickel plated suspension and I have the odd rattle that still annoys me. But in general, still loving my Etype.

I also plucked up the courage to finally let my wife drive it - strangely she declined and said maybe another day. In 18 years of being a passenger she is still scared of hurting it :)
1964 FHC 4.2
Etype restoration blog http://connor.org.uk

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

mgcjag
Moderator
Posts: 5258
Joined: Fri Jul 09, 2010 6:15 pm
Location: Ludlow Shropshire
Great Britain

#2 Re: Its been a while...

Post by mgcjag » Wed Feb 27, 2019 1:14 pm

Hi Chris....welcome back......Steve
Steve
1969 S2 2+2 & Building a C type replica

Link:
BBcode:
HTML:
Hide post links
Show post links


Polse7317
Posts: 584
Joined: Tue Oct 02, 2012 12:41 pm
Location: FRANCE Aquitaine
France

#3 Re: Its been a while...

Post by Polse7317 » Wed Feb 27, 2019 6:45 pm

Hi Chris you were a great help for my restoration adventure…... :salute:
I have a blog on a french site : motorlegend and have now much question from new "restorers" about restoration…. So i can pass my little knowledge to others as you did with me …! :thumbsup:
Yves, happy XKE 63 fhc , w113 280sl owner
Looking for a OTS 4.2 serie 1....! :scratchheadyellow: and now have found a fhc xk 140 :lol:

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

Topic author
ChrisC
Posts: 1273
Joined: Sun Feb 14, 2010 11:38 am
Location: Surrey UK
Contact:
Great Britain

#4 Re: Its been a while...

Post by ChrisC » Thu Feb 28, 2019 4:38 pm

Perfect :) that's what this forum is all about...

Glad I could help you.
1964 FHC 4.2
Etype restoration blog http://connor.org.uk

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

ralphr1780
Posts: 945
Joined: Wed Apr 11, 2012 4:29 pm
Belgium

#5 Re: Its been a while...

Post by ralphr1780 » Fri Mar 01, 2019 1:00 pm

Welcome back Chris, I have benefited as well much from your site and blog, thanks for that :yellow:
Ralph
'69 OTS + '62 OTS - Belgium

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

Simon P
Posts: 1040
Joined: Thu Oct 14, 2010 4:29 pm
Location: London
Great Britain

#6 Re: Its been a while...

Post by Simon P » Mon Mar 11, 2019 6:02 pm

Good to see you back again!

:thumbsup:
1969 S2 FHC - 1R20258
1993 Lancia Delta HF integrale Evo II

Link:
BBcode:
HTML:
Hide post links
Show post links


SteveG
Posts: 124
Joined: Wed Aug 17, 2011 7:44 pm
Location: North Devon
Great Britain

#7 Re: Its been a while...

Post by SteveG » Wed Mar 20, 2019 4:18 pm

Hi Chris,

Welcome back! I too have been absent for a couple of years until recently from all things Jaguar as remarried / moved house (twice) and moved my E type more times than I care to remember :roll: Pleased you are still enjoying your wonderful restoration.

Good to hear you’re still about.
Steve - 1966 2+2 1E50101 slow restoration

Link:
BBcode:
HTML:
Hide post links
Show post links

Post Reply Previous topicNext topic