Battery drain

Technical advice Q&A
User avatar

Topic author
rswaffie
Posts: 801
Joined: Sat Jul 19, 2014 7:56 am
Location: Lincolnshire
Great Britain

#1 Battery drain

Post by rswaffie » Sun Sep 08, 2019 1:45 pm

Hi,
I’ve put 150 miles on my freshly restored car and the snagging list is in the ‘running reports’ section.
However, something has come to light that I’m having difficulty fixing.
I normally isolate the battery via a ‘dis-car-nect’ Type device. However, after the latest run, I forgot. When I went to start it after about 24hrs, dead battery.
I recharged it overnight and did a drain test with my multi meter and it showed 2.8amps, which is not good from what I understand. I pulled each fuse in turn, checking the ammeter each time and could not see any change - still 2.8.
I checked all the main earth connections and all seem ok.
Anyone got any thoughts?
Richard

S1 3.8 FHC Opalescent Golden Sand with Tan Trim 889504
Nearing completion of a comprehensive nut ‘n’ bolt restoration in my small, but utilitarian garage :wrench: :hammer: :fingerscrossed:

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

Heuer
Administrator
Posts: 12722
Joined: Sat Mar 01, 2008 5:29 pm
Location: Nottinghamshire
Great Britain

#2 Re: Battery drain

Post by Heuer » Sun Sep 08, 2019 1:48 pm

A current draw of 2.8 amps is huge with everything switched off! That is about 35 watts being dissipated so something will be getting very warm. What sort of generator are you using?

Quick test - disconnect the generator/alternator (all wires) and measure again.

If you have a Laser thermometer try checking for heat or use your hands. Check the starter motor as well. If you can't smell burning it must be flowing through something heavy.
David Jones
S1 OTS OSB; S1 FHC ODB

Add your E-Type to our World Map: viewtopic.php?f=1&t=1810

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

Topic author
rswaffie
Posts: 801
Joined: Sat Jul 19, 2014 7:56 am
Location: Lincolnshire
Great Britain

#3 Re: Battery drain

Post by rswaffie » Sun Sep 08, 2019 1:58 pm

David, you are spot on. Disconnected the powerlite Dynator and 0 draw.
The unit is charging the battery ok, so any view on what might be causing it to do this?
Richard

S1 3.8 FHC Opalescent Golden Sand with Tan Trim 889504
Nearing completion of a comprehensive nut ‘n’ bolt restoration in my small, but utilitarian garage :wrench: :hammer: :fingerscrossed:

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

Heuer
Administrator
Posts: 12722
Joined: Sat Mar 01, 2008 5:29 pm
Location: Nottinghamshire
Great Britain

#4 Re: Battery drain

Post by Heuer » Sun Sep 08, 2019 2:14 pm

Sounds like the Dynator is faulty (maybe a diode gone bad) as it is allowing current to flow in reverse. Check with the supplier but whilst it may be OK to run the car you must disconnect the battery when the engine is off otherwise you will knacker the battery.

Another test you can do is to disconnect each wire and measure. This will tell us whether it is the field coil, or energising coil.

How have you wired it - with or without the RB340?

Image
David Jones
S1 OTS OSB; S1 FHC ODB

Add your E-Type to our World Map: viewtopic.php?f=1&t=1810

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

Topic author
rswaffie
Posts: 801
Joined: Sat Jul 19, 2014 7:56 am
Location: Lincolnshire
Great Britain

#5 Re: Battery drain

Post by rswaffie » Sun Sep 08, 2019 2:45 pm

Hi David, it’s wired with a ‘dummy’ rb340, as per below:


Image
Richard

S1 3.8 FHC Opalescent Golden Sand with Tan Trim 889504
Nearing completion of a comprehensive nut ‘n’ bolt restoration in my small, but utilitarian garage :wrench: :hammer: :fingerscrossed:

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

Heuer
Administrator
Posts: 12722
Joined: Sat Mar 01, 2008 5:29 pm
Location: Nottinghamshire
Great Britain

#6 Re: Battery drain

Post by Heuer » Sun Sep 08, 2019 3:51 pm

Disconnect 'D' and measure
Reconnect 'D', disconnect 'F' and measure

Which one (or both) show the current drain?
David Jones
S1 OTS OSB; S1 FHC ODB

Add your E-Type to our World Map: viewtopic.php?f=1&t=1810

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

Topic author
rswaffie
Posts: 801
Joined: Sat Jul 19, 2014 7:56 am
Location: Lincolnshire
Great Britain

#7 Re: Battery drain

Post by rswaffie » Sun Sep 08, 2019 4:17 pm

Thanks David.
When I disconnect D at the Dynator, no drain.
D reconnected, F disconnected at the Dynator, no drain.
Richard

S1 3.8 FHC Opalescent Golden Sand with Tan Trim 889504
Nearing completion of a comprehensive nut ‘n’ bolt restoration in my small, but utilitarian garage :wrench: :hammer: :fingerscrossed:

Link:
BBcode:
HTML:
Hide post links
Show post links


dal2.0litrefrogeye
Posts: 874
Joined: Fri Aug 06, 2010 10:48 pm
Location: sarf london
Contact:
Great Britain

#8 Re: Battery drain

Post by dal2.0litrefrogeye » Sun Sep 08, 2019 4:55 pm

In all seriousness ( and you won't get that from me that often ) I'd disconnect battery and take dynalite off a d return for repair / replacement .......... an electrical fire ain't funny
Its a way of life not a hobby
Darren . 64 4.2 modded 69 4.2

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

Heuer
Administrator
Posts: 12722
Joined: Sat Mar 01, 2008 5:29 pm
Location: Nottinghamshire
Great Britain

#9 Re: Battery drain

Post by Heuer » Sun Sep 08, 2019 5:09 pm

rswaffie wrote:
Sun Sep 08, 2019 4:17 pm
Thanks David.
When I disconnect D at the Dynator, no drain.
D reconnected, F disconnected at the Dynator, no drain.
It appears there is an internal short of some kind between D and F and it could be in the faux RB340. Final test is to wire it up as per the diagram I posted and not use the internal regulator shunt. If you still have the drain then it is most certainly the Powerlite. So pull the F and WL wires/spades from the RB340 and connect them together as per my diagram. If you still have the issue then it is the Dynator.
David Jones
S1 OTS OSB; S1 FHC ODB

Add your E-Type to our World Map: viewtopic.php?f=1&t=1810

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

Topic author
rswaffie
Posts: 801
Joined: Sat Jul 19, 2014 7:56 am
Location: Lincolnshire
Great Britain

#10 Re: Battery drain

Post by rswaffie » Wed Sep 11, 2019 9:38 am

Thanks David.
I’ve been looking at the wiring from the unit to the dummy regulator as Powerlite have suggested that an internal fail safe has been triggered due to incorrect installation. It looks like that when the engine was fitted, the upgraded cable from the unit D terminal was terminated at the battery post on the starter solenoid, as opposed to the D terminal on the dummy rb340. Is this likely to be the cause?
Richard

S1 3.8 FHC Opalescent Golden Sand with Tan Trim 889504
Nearing completion of a comprehensive nut ‘n’ bolt restoration in my small, but utilitarian garage :wrench: :hammer: :fingerscrossed:

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

Heuer
Administrator
Posts: 12722
Joined: Sat Mar 01, 2008 5:29 pm
Location: Nottinghamshire
Great Britain

#11 Re: Battery drain

Post by Heuer » Wed Sep 11, 2019 10:54 am

Doubt it as they are all on the same circuit but without a wiring diagram for the dummy regulator it is difficult to be certain what they have going on. I suggest you ignore the dummy regulator temporarily and connect up using the old Powerlite diagram and original RB340 as in my above post.

The D wire should just connect to the battery -ve with an internal link in the dummy. Suggest you ask Powerlite for a wiring diagram of the dummy box. They seem to be a good and reliable company so they should do as you request. This is the trouble with fitting anything proprietary to the car that does not have any open source documentation - it makes problem solving a nightmare. Imagine being stuck in France on holiday with this problem!

Incidentally are you +ve or -ve earth with this setup?
David Jones
S1 OTS OSB; S1 FHC ODB

Add your E-Type to our World Map: viewtopic.php?f=1&t=1810

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

Topic author
rswaffie
Posts: 801
Joined: Sat Jul 19, 2014 7:56 am
Location: Lincolnshire
Great Britain

#12 Re: Battery drain

Post by rswaffie » Wed Sep 11, 2019 11:10 am

I’m positive earth. I did a continuity test between the D and battery terminals on the dummy reg and they are connected internally.
One of their resellers/installers are local to me so I’m going to send the unit back and get them to check all the wiring and refit it.
Richard

S1 3.8 FHC Opalescent Golden Sand with Tan Trim 889504
Nearing completion of a comprehensive nut ‘n’ bolt restoration in my small, but utilitarian garage :wrench: :hammer: :fingerscrossed:

Link:
BBcode:
HTML:
Hide post links
Show post links

Post Reply Previous topicNext topic