Speedometer

Technical advice Q&A

Topic author
Bernie2015
Posts: 169
Joined: Fri Oct 16, 2015 4:30 pm
Location: Devon
Great Britain

#1 Speedometer

Post by Bernie2015 » Thu Sep 20, 2018 2:54 pm

Decided to take my speedometer out as not working and found the cable is disconnected. Also some oil around the top of the cable. Tested it by inserting a piece to take place of the cable and it registers a speed so hopefully it functions correctly. However unfortunately while tinkering with it a couple of parts fell out (see photo)
1 The ignition light lens
2 Unknown??
Has anyone seen a part like this before? Have I done for the speedo? Should leave it to the professionals I suppose but enjoy tinkering!
Image
Bernie 1966 S1 OTS

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

Mich7920
Posts: 412
Joined: Sun Mar 15, 2015 4:43 pm
Location: France
France

#2 Re: Speedometer

Post by Mich7920 » Thu Sep 20, 2018 3:41 pm

Hi Bernie,
Luckily you don't have disassemble the screen of the speedo. Stop now.
- The ignition light lens is design like a mushroom. You have the head but ther foot is broken. Same for the fuel and headlamps
- The second part is the 0 stop of your speedometer needle.
Definitely send it to a professionnal !
http://www.speedycables.com did a very good for me.
And at last, don't worry you'll have a lot of other occasion to tinkering on your E !
Mich
Michel
1963 E Type OTS - Angus Restoration
1965 E Type FHC - Front Restoration

Link:
BBcode:
HTML:
Hide post links
Show post links

Post Reply Previous topicNext topic