Ignition Relay woes

Technical advice Q&A
User avatar

Topic author
ALAN COCHRANE
Posts: 599
Joined: Sun May 06, 2012 9:37 am
Location: Fife
Great Britain

#1 Ignition Relay woes

Post by ALAN COCHRANE » Sun May 12, 2019 10:12 pm

Well today one of my upgrades let me down on the way to my first car show of the year.
A while back the ignition started cutting out on me intermittently because the internal contacts in the key barrel had started burning away due to the load it was switching. I replaced the barrel and added a Durite relay to switch the ignition load.
This worked faultlessly until today when the car coasted to a stop on the approach to a narrow bridge.
The relay started to smoke when I tried to reconnect the load wires and that was it well and truly fried. Unfortunately for some unknown reason I didn't carry any spare relays but I did have a set of leads, one of which allowed me to short out the ignition barrel and relay and get me home.
Keyless ignition in an E-Type-very 21st century!
Once home I quickly replaced the relay with a Lucas unit from my stock and we were off again.
A lesson learned-carry spare relays, although now that I have two in the boot I'll bet they never see the light of day again.
I bought the Durite relay because they were made in the UK and were supposed to be a quality item. Has anyone else used them and experienced similar problems?

Cheers

Alan
1962 S1 OTS-850389,1968 Triumph TR250, 1971 Triumph GT6 Mk3, 2008 Porsche Boxster RS60 Spyder

Link:
BBcode:
HTML:
Hide post links
Show post links