Creak when depressing clutch with engine off

Talk about the E-Type Series 1
User avatar

Topic author
Philk
Posts: 143
Joined: Wed Dec 07, 2016 7:48 am
Great Britain

#1 Creak when depressing clutch with engine off

Post by Philk » Sun Jul 08, 2018 8:43 am

A question forthose 3.8 owners with a standard clutch and gearbox set up...… with the engine off, does anyone experience a loud creak from within the bell housing when depressing the clutch to the full extent? I get a loud creak when the clutch goes through the last inch or so of travel. It's definitely not coming from the pedal box or master cylinder. Listening from under the car with someone operating the clutch, the noise seems to be coming from inside the bell housing. The clutch works perfectly fine. When the engine is running there is too much other noise to see if the creak is still present. Clutch and master/slave cylinders were both replaced 800 miles ago.
Phil
1964 S1 3.8 OTS

Link:
BBcode:
HTML:
Hide post links
Show post links


cactusman
Posts: 1495
Joined: Wed Nov 14, 2012 11:09 pm
Location: Hertfordshire
Great Britain

#2 Re: Creak when depressing clutch with engine off

Post by cactusman » Tue Jul 10, 2018 3:54 pm

Could be the release arm fulcrum point, the release bearing or the clutch plate itself as pressure is applied. Mine doesn't creek but if it works ok, does not drag or make horrible noises when running it is probably not significant IMO. :bigrin:
Julian the E-type man
1962 FHC
1966 MGB....fab little car too

Link:
BBcode:
HTML:
Hide post links
Show post links

Post Reply Previous topicNext topic