Turn Signal Help

Talk about the E-Type Series 2

Topic author
FHCINSC
Posts: 10
Joined: Sun Nov 04, 2018 7:55 pm
United States of America

#1 Turn Signal Help

Post by FHCINSC » Mon Nov 26, 2018 9:16 pm

Hello. My 69 FHC front left turn signal works but the front right does not.
I decided to remove the fixtures because it looks like they were not cleaned up well during the restore of my car.
One concern is that they don’t match. The left one has only one bulb. The right one has 2 bulbs. Also notice the wiring difference on the fixtures.
My meter is not showing any power to the wires for the right signal so I suppose I need to look upstream at the relay or the hazard switch?
Thanks all!!

Image

Image

Image

Image

Link:
BBcode:
HTML:
Hide post links
Show post links


Tom W
Posts: 99
Joined: Sat May 05, 2018 10:18 am
Location: UK
Great Britain

#2 Re: Turn Signal Help

Post by Tom W » Tue Nov 27, 2018 7:33 am

You really need the wiring diagram to find the fault. Do all the lights work when the hazards are switched on? If so, then you can confirm the wiring to the bulb is good. As the left hand side is good, then you know the flasher relay works ok. As both lights on the right don’t work, I’d suspect the switch or the wiring immediately after it. There’s a bundle under the dash on mine that has given problems in the past. Intermittent bullet connector continuity! As for the dissimilar lamps, maybe you have one off a series 3? Series 2 lights, for the UK at least, should have direction indicators and side lights.
Tom
1970 S2 FHC

Link:
BBcode:
HTML:
Hide post links
Show post links


Topic author
FHCINSC
Posts: 10
Joined: Sun Nov 04, 2018 7:55 pm
United States of America

#3 Re: Turn Signal Help

Post by FHCINSC » Tue Nov 27, 2018 10:51 pm

Thanks Tom. I’m actually worried about the wiring diagram issue because as you can see there are some non-standard colors in those wires hanging out of the right hand side (blue and white).

Link:
BBcode:
HTML:
Hide post links
Show post links


Tom W
Posts: 99
Joined: Sat May 05, 2018 10:18 am
Location: UK
Great Britain

#4 Re: Turn Signal Help

Post by Tom W » Tue Nov 27, 2018 11:01 pm

What year is your car, and is is UK or US spec etc? There’s several versions of S2 wiring, not every wiring diagram captures everything. I still have original wires in mine I’ve not found reference to on any wiring diagram. Blue and white is typically associated with main beam, according to this https://www.autoelectricsupplies.co.uk/ ... rder_2.pdf
Tom
1970 S2 FHC

Link:
BBcode:
HTML:
Hide post links
Show post links


288gto
Posts: 886
Joined: Wed Nov 14, 2012 8:59 pm
Location: United Kingdom
Russia

#5 Re: Turn Signal Help

Post by 288gto » Tue Nov 27, 2018 11:49 pm

US and UK

Blue/white. Main beam
Blue/red. Dip beam
Green/white. Indicator right
Green/red. Indicator left
Red. Side light
Black . Earth

The light housing you have with one bulb holder is for a US spec car or a Series 3 and the one with two is for a UK spec car with side lights that have the split amber and clear lens.

On a Series 2 car the current for the indicators passes through the stalk switch AND the hazard rocker switch so both need checking along with the bullet connectors on the stalk switch and under the dash at the bottom of the screen pillars.
The bonnet multi pin connector is another area to check. This is all assuming you have ruled out a bad connection at the bulb holder. The centre pin on the bulb holder should be the live terminal and the outer bayonet or screw part the earth.

Hope that helps.

Simon
Simon
1969 S2 OTS

Link:
BBcode:
HTML:
Hide post links
Show post links


Topic author
FHCINSC
Posts: 10
Joined: Sun Nov 04, 2018 7:55 pm
United States of America

#6 Re: Turn Signal Help

Post by FHCINSC » Wed Nov 28, 2018 4:24 am

Thanks so much to you all.
My car is a 69 US spec but all wiring harnesses have been replaced by the person who did the bulk of the restoration.
I’ll do some digging around with this info. Thanks again!

Link:
BBcode:
HTML:
Hide post links
Show post links


Topic author
FHCINSC
Posts: 10
Joined: Sun Nov 04, 2018 7:55 pm
United States of America

#7 Re: Turn Signal Help

Post by FHCINSC » Thu Dec 06, 2018 1:12 am

Hello. I’ve had quite an adventure. One of the things I decided to do is simplify the connections by eleiminating the terminal block inside the hood. I used heat shrink connectors and heat shrink rubber tubing instead.
The wiring for the signal was detached at the bonnet pin connector....both sides of it actually.

The bad news is that the front signals are reversed now (left and right) and high beam low beam are reversed.
I used the wiring diagrams posted for the S2 so I know my wire colors are correct. I believe the signal wires must need to be corrected in the dash. Either the flasher or at the stalk?

Issue with the high beams is that the blue light is on in the dash gauge when low beams are on.

The journey continues! Thanks all!
Anthony

Link:
BBcode:
HTML:
Hide post links
Show post links

Post Reply Previous topicNext topic