Strange noise

Talk about the E-Type Series 3
User avatar

Topic author
driver
Posts: 93
Joined: Sat Sep 24, 2016 8:48 pm
Great Britain

#1 Strange noise

Post by driver » Sun Dec 08, 2019 6:06 pm

Hi Rob Gill here ,

the engine on my v12 seems to run well (good oil pressure no noises etc ).
BUT ,I HAVE ALWAYS BEEN AWARE OF SLIGHT TINNY /METALIC NOISEJUST OCASIONALLY ON THE ENGINE OVER RUN FROM LOW REVS ,I VERY RARELY GO OVER 2500/3000 RPM.HAVE CHECKED ALL THE USUAL MOVING PARTS AND HEAT SHEILDS ETC.THE TIMING CHAIN GIVES OFF NO NOISE ON TICK OVER OR ON NORMAL RUNNING.I AM WONDERING IF IT COULD BE A WORN TENSIONER OR GUIDE …..ANY THOUGHTS OR IDEAS ON THIS ONE GENTS.
THANKS IN ANTICIPATION
ROB :scratchheadyellow:
v12 etype 2+2

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

Ole-xke1974
Posts: 179
Joined: Sat Nov 08, 2014 9:52 am
Location: Holmfirth, West Yorkshire
Great Britain

#2 Re: Strange noise

Post by Ole-xke1974 » Tue Dec 10, 2019 1:53 am

Rob,
what do you mean by overrun from low revs ?
I'd expect a tinny or knocking noise under acceleration if you have one or more of these:
  • Lean fuel mixture
    Incorrect ignition timing
    Wrong type of spark plug
    Poor quality gasoline
Cheers ........ Ole
1974 SIII E-Type w. XJ S2 4sp w. O/D

Link:
BBcode:
HTML:
Hide post links
Show post links


ManniB
Posts: 31
Joined: Sat Oct 17, 2015 9:01 am
Location: Pfaffenhofen/Germany
Germany

#3 Re: Strange noise

Post by ManniB » Tue Dec 10, 2019 11:16 am

Rob,

don't forget to check your exhaust manifolds for a leak. It can sound much like what you describe.

- Manfred
1972 E type 2+2 Willow Green

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

MLBS3V12
Posts: 456
Joined: Thu May 19, 2011 6:57 pm
Location: France
France

#4 Re: Strange noise

Post by MLBS3V12 » Wed Dec 11, 2019 4:42 am

Maybe this is because the spring below is nt there:


Image
Le chemin sera long!...

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

Ole-xke1974
Posts: 179
Joined: Sat Nov 08, 2014 9:52 am
Location: Holmfirth, West Yorkshire
Great Britain

#5 Re: Strange noise

Post by Ole-xke1974 » Fri Dec 13, 2019 1:37 pm

MLBS3V12 wrote:
Wed Dec 11, 2019 4:42 am
Maybe this is because the spring below is nt there:
Good call I
Certainly a possible reason I didn't think about.
That spring is there to prevent the SS shield from rattling.
1974 SIII E-Type w. XJ S2 4sp w. O/D

Link:
BBcode:
HTML:
Hide post links
Show post links

Post Reply Previous topicNext topic