Fuel Pump no ticking when fuel line connected

Talk about the E-Type Series 2
User avatar

Topic author
nefematic
Posts: 345
Joined: Sun Aug 12, 2012 4:18 pm
Location: Stuttgart, Germany
Germany

#1 Fuel Pump no ticking when fuel line connected

Post by nefematic » Thu Aug 25, 2022 2:41 pm

A bit baffled here. Got back from England over 2000km no problems. Yesterday car won‘t start, no tick from the SU fuel pump. I‘ve taken the pump out and disconnected the fuel lines. Ticks nicely. Put the fuel lines back on, no more ticking.

Is this pump a goner? 7 years old, around 10000km.

After fiddling around checking voltage with ignition on, the pump gets hot, is that a clue?

Any advice?

Martin

https://youtube.com/shorts/mGqoKMvNES8?feature=share
Martin Scherz
Late S2 1970 OTS US LHD

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

mgcjag
Moderator
Posts: 7285
Joined: Fri Jul 09, 2010 6:15 pm
Location: Ludlow Shropshire
Great Britain

#2 Re: Fuel Pump no ticking when fuel line connected

Post by mgcjag » Thu Aug 25, 2022 3:09 pm

Hi Martin.....is there a blockage in the fuel line preventing fuel getting through to carbs. .....so pump stops ticking....disconnect the hose at the carbs or fuel filter and see if fuel pumps through. .....Steve
Steve
69 S2 2+2 (just sold) & Building a C type replica, 1960 xk150fhc

Link:
BBcode:
HTML:
Hide post links
Show post links


christopher storey
Posts: 5556
Joined: Sun Mar 09, 2008 3:07 pm
Location: cheshire , england
Great Britain

#3 Re: Fuel Pump no ticking when fuel line connected

Post by christopher storey » Thu Aug 25, 2022 5:29 pm

I agree that this is likely to be a blockage in the fuel line . Try removing the filter element from the fuel bowl and see if it then works

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

mgcjag
Moderator
Posts: 7285
Joined: Fri Jul 09, 2010 6:15 pm
Location: Ludlow Shropshire
Great Britain

#4 Re: Fuel Pump no ticking when fuel line connected

Post by mgcjag » Thu Aug 25, 2022 5:32 pm

Good call Christopher. ....with the "new" replacement elements sedement collects inside the paper element and cannot be seen in the glass bowl.....Steve
Steve
69 S2 2+2 (just sold) & Building a C type replica, 1960 xk150fhc

Link:
BBcode:
HTML:
Hide post links
Show post links

User avatar

Topic author
nefematic
Posts: 345
Joined: Sun Aug 12, 2012 4:18 pm
Location: Stuttgart, Germany
Germany

#5 Re: Fuel Pump no ticking when fuel line connected

Post by nefematic » Fri Aug 26, 2022 7:50 am

OK so I opened the fuel line coming out of the filter head, nice pressure from there:

https://youtube.com/shorts/V7AdDtzr7sc?feature=share

This evening I‘ll take out out the paper filter and check the inside. It has has roughly 10tkm so needs a change anyway.

Meanwhile after fuel flow check pump ticks over and engine running again. Took it up the hills for half an hour to make it suffer. I haven’t redlined it since engine overhaul but I’m getting there. ;)

I’ll get back with what is found inside the filter.
Martin Scherz
Late S2 1970 OTS US LHD

Link:
BBcode:
HTML:
Hide post links
Show post links

Post Reply Previous topicNext topic